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Overview 
 To be able to use the Export Schedules facility, a user must have (or be a 
member of a group that has) the daExport operations permission. 

Vitalware 2.1.02 introduces a new facility that enables data to be exported on a 
regular basis. Users can define: 

• A set of fields for export. 
• A sort order for the exported records. 
• A TexQL statement to determine which records to export. 
• Dates on which the export is to occur. 

Data can be scheduled to be exported on anything from a daily to an annual basis. The 
export occurs outside working hours (generally early in the morning) and the results 
are stored on the Vitalware server. A user may then view the results and save / view 
the export files produced. 

The Scheduled Exports facility provides two new modules: 

• Schedules  
Holds one record per Scheduled Export containing the definition of the export (as 
defined above). 

• Exports  
Holds one record per set of export files produced. When a Scheduled Export is 
run a new exports record is created containing the output of the export process. 

See The Schedules and Exports Modules (page 35) for more details. 

An audit of all Scheduled Exports is produced and these records are not removed 
from the system, so it is possible to search / view all exports performed by all users 
(provided that you have sufficient privileges to do so). 

When a Scheduled Export is executed, the default output is XML, which is the same 
format used by the Vitalware reporting facility. A filter may be set to transform the 
XML produced into another format (CSV for example). System Administrators may 
define their own filters to produce custom output formats. A custom filter may also be 
used to: 

• Email export files to users. 
• Print export files. 
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• Copy export files to a known location (for collection). 
• Transmit export files to another machine. 

See Creating Filters (page 39) for more details on how to create custom filters. 
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Creating a Scheduled Export 
Configuring a Scheduled Export is very similar to configuring a report. In fact the 
Properties dialog box used to select the fields for export is the same as used by the 
reporting process. In this section we step through the creation of a new Scheduled 
Export. 
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Set up the Export schedule: the Export tab 
In the module from which the records are to be exported: 

1. Search for or otherwise list a group of records. 
2. Select Tools>Exports in the Menu bar. 

-OR- 
Use the keyboard shortcut, ALT+T+X. 
The Exports dialog box displays with a list of all Scheduled Exports for the 
current module: 

 

3. Select New  
-OR- 

Select New  
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The Export Properties dialog box displays: 

 
4. Enter a descriptive name for the Export Schedule in the top text field. 

The title will display in the Exports dialog box, from where it can be selected by 
authorized users to run the export on an adhoc basis. 

5. If you require the exported data to be transformed from XML format to another 
format (e.g. CSV), select a filter from the Filter (optional) drop list. 
Filters are defined by the System Administrator. If a filter is not selected, the 
exported data is saved in Vitalware XML format. See Creating Filters (page 39) 
for more details. 

6. Select the language of the data to be exported from the Language drop list.  
A language may only be selected if your Vitalware system supports more than 
one data language. Any of the available languages in which data is recorded may 
be selected or All Languages may be used to export the complete contents of 
the exported fields. 

7. Enter the first date on which the export will be produced in the Start Date field. 
This date is also used to calculate the next time an export should occur when the 
report frequency is specified as a number of days / months / years.  
The format of the date (e.g. dd/mmm/yyyy) is as specified for your Vitalware 
system.  
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A start date must be provided. 
8. Enter an end date in the Finish Date field. 

 An end date is not required, however if specified, data will not be exported after 
that date has been reached. An empty end date implies no final date for 
exporting data. 

9. Select an export frequency from the Frequency drop list.  
There are four frequency values to choose from: 

 

Adhoc Use Adhoc when defining an export that will not be run at a regular interval, 
for example if you are contacted irregularly to produce the export data.  
As the export is not scheduled, it must be run manually to produce the export 
data. See Unscheduled Exports (page 27) for more details. 

Daily Use Daily if the data is exported on anything less than a monthly basis. The 
following options are displayed when Daily is selected: 

 
 There are three ways to configure daily exports: 
 1. The simplest is to select the days of the week on which the export is 

to occur. The export is run early in the morning of the day(s) selected. 
If no Finish Date is specified, the export will run every week on the 
specified day(s). 
Typically an export would be run once per week or every day.  
If there is an interval between exports (the export is scheduled for 
Sunday and Thursday, for instance), the records exported on Sunday 
would be from the previous Thursday, and the records exported on 
the Thursday would be from the previous Sunday. 

 2. Specify the number of days between exports (starting from the Start 
Date) in the Every nnn Day(s) field.  
For example, a value of 14 indicates that the export is to be run 
fortnightly from the Start Date. 
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 3. Specify the day on which an export will first be run and the interval 
between exports. 
For example, a value of Every 14 Day(s), with Thursday selected 
indicates that an export will commence on the first Thursday after or 
on the Start Date and will run every 14 days. 

Monthly Use Monthly when data exports occur on a monthly basis but less than 
annually. The following options are displayed when Monthly is selected: 

 
Specify how may months must elapse between each report using the Every 
nnn Month(s) field. If a value is not given, the export will occur monthly. For 
example, a value of 3 indicates that the export will occur quarterly. 
Use the Day nnn of the Month field to specify on what day in the month the 
export is to occur. A value of 1 indicates that the export will run on the first 
day of the month. A value of 31 implies the last day of the month, regardless 
of how many days are in the month. 
The First Weekday of the Month checkbox may be selected instead of 
specifying a day of the month. In this case, the export is run early in the 
morning on the first Monday of the month. 
A value must be supplied for either Every nnn Month(s) or the First Weekday 
of the Month. 
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Annually Use Annually for any data export required on a yearly basis. The following 
options are displayed when Annually is selected: 

 
There are three ways to configure annual exports: 

 1. Specify the day of the year on which the export is to take place using 
the Day nnn of the Year field. A value between 1 and 365 can be 
used. 

 2. Specify a specific day in a given month using the Day nnn and Month 
mmm of Each Year field. 
For example, a setting of Day 1 and Month July of Each Year would 
allow data up to and including 30 June to be exported. 

 3. The First Weekday of the Year checkbox may be selected instead of 
specifying a day within a month. In this case, the export is executed 
early in the morning of the first Monday of the Year. 
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Select the fields to include in the export: 
the Fields tab 

1. In the Export Properties dialog box, select the Fields tab. 
Here we add the fields to be exported. 

2. Select Add . 
The Export Fields box displays with a list of all fields in the current module, as 
well as fields in attached modules (an attachment field is indicated by the plus  
icon): 

 

3. In the Export Fields dialog box, select a field and select Add  
-OR- 
Double-click a field. 
The field is added to the Fields list in the Export Properties box. 

4. When all required fields are added, select Close  in the Export Fields 
dialog box. 
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The Export Properties dialog box now lists all the fields that will be included in 
the export: 

 
For more details regarding the selection of fields for export see Select the fields to 
include in the report: the Fields tab in the Reports section of the Vitalware help. 
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Determine which records to export: the 
Conditions tab 

1. In the Export Properties dialog box, select the Conditions tab. 
On the Conditions tab we add a TexQL statement to determine which records will 
be exported. 

2. Enter a TexQL statement into the Conditions text box. 
The following placeholders may be used in the TexQL statement: 
#TODAY# This placeholder is replaced with the date on which the 

export is run. The date order used (e.g. day/month/year, 
month/day/year) is as specified for your Vitalware 
system. 

#STARTDATE# This placeholder is replaced with the date of the first day 
after the end date of the previous export. It is used for 
date range queries to specify the starting date for the 
exported records. 

#ENDDATE# This placeholder is replaced with the date of the last day 
for the records to be exported. The end date is always the 
day before the scheduled date as exports are run early 
in the morning of the scheduled day. 

#MONTH# This placeholder is replaced with the month of the day 
that falls immediately prior to the day of the export. 
The month is a number between 1 and 12. 
For example, if the export date is 3 May, #MONTH# is 5 
(May); if the export date is 1 May, #MONTH# is 4 (April).  

#YEAR# This placeholder is replaced with the year of the day prior 
to the execution of the export. 

 Placeholders use the day before the date on which the export is run as the 
closing date because exports are run early in the morning: the closing date for 
searches does not include the current date as the day is not yet complete. 
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When the Export Properties dialog box is closed by selecting the OK button, the 
TexQL statement is checked to ensure that a valid query has been specified: 
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Hint - Determining the TexQL Conditions statement 
A TexQL condition statement is a query used to retrieve the records to be exported. 
Any valid TexQL query statement may be used. Unfortunately the format of the 
statement may be hard to piece together unless you are familiar with SQL. 
Fortunately Vitalware provides an easy mechanism for generating a statement based 
on query terms entered into the current module. 

1. Open the module from which the records are to be exported. 
The module should be in Search mode. 

2. Enter search terms as though you were retrieving the records you would like to 
export. 

 Note that there may be search terms specified in a module by default. If these 
are not required, clear them. 

Where you want to use a date range containing place markers, enter the place 
marker into the control: 

 
3. Select File>Show Search in the Menu bar 

-OR- 
Use the keyboard shortcut, ALT+F+O. 
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The Edit Search dialog box displays: 

 
4. Copy the contents of the Edit Search box. 

5. Select Abort . 
The Edit Search box is closed. 
The TexQL condition statement to use for your export can now be pasted into the 
Conditions tab when defining your Export Properties. 
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Define sort order: the Sort Order tab 
1. In the Export Properties dialog box, select the Sort Order tab. 

All fields in the module are listed in the Fields list. 

2. Select a field in the Fields list and select Add  to add it to the Order 
list. 
-OR- 
Double-click the field name in the Fields list: 

 
Add as many fields on which to sort as required. 
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Set sort options: the Options tab 
1. In the Export Properties dialog box, select the Options tab: 

 
2. Select the required Sort Options. 

For more details regarding sort options see Set sort options: the Options tab in 
the Reports section of the Vitalware help. 
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Set security options: the Security tab 
On the Security tab we determine who is authorized to run your export by adding 
users or groups to the Access list: 

1. In the Export Properties box, select the Security tab: 

 
2. Select a user / group name (e.g. Everyone) in the Names box and select Add 

 
-OR- 
Double-click the user / group name in the Names list. 
The name is added to the Access list. 

3. Select OK . 
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Any TexQL statement added on the Conditions tab is now validated and if all is 
well the new scheduled export will display in the Exports dialog box:  
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Examples 

Scenario 1 
A births record creation project is under way. As part of the outputs of the project a 
weekly file is to be produced containing the Registration Number, Child's Given 
Names, Child's Surname, Date of Birth, Mother's Given Name, Mother's Surname of 
all records added in the week. 

Solution 

As the file is to be produced weekly, the export frequency required is Daily (as the 
frequency is less than monthly). The Sunday checkbox should be selected. As no 
Finish Date is specified, these settings will result in the export running early Sunday 
morning, once a week, exporting all data from the previous Sunday through to the 
Saturday. 

The Conditions statement needs to query for all records inserted into the Births 
module in the previous week. As the export is run once a week the #STARTDATE# 
placeholder will be set to the date of the previous Sunday and the #ENDDATE# will be 
the date of the Saturday immediately before the export is run. 

For example, if the export is run on the morning of Sunday, 14 February 2010, then 
#ENDDATE# will be 13 February 2010 (Saturday) and #STARTDATE# will be 7 February 
2010 (the previous Sunday). The required Conditions statement is: 
SELECT all 
FROM   ebirths 
WHERE  AdmDateInserted >= DATE '#STARTDATE#'  
AND    AdmDateInserted <= DATE '#ENDDATE#' 

The Export and Conditions tabs are: 
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Scenario 2 
A quarterly export of all records of deaths where the deceased's age is 18 years or 
younger is required by the Health Department. The export must list the Registration 
Number, Deceased's Given Names, Surname, Date of Death and Date of Birth. 

Solution 

Since the export is required every three months, the Monthly export frequency 
should be chosen. The Every nnn Month(s) field should be set to 3 to ensure the 
export only occurs once every three months (that is, quarterly). The Day nnn of the 
Month field should be set to 1 as we want the export to include all records up to but 
not including the first day of the month. Finally the Start Date needs to be set to the 
first day of a quarterly date boundary. If our quarters start on 1 January, 1 April, 1 
July and 1 October, then one of these dates should be chosen. 

The Conditions statement needs to retrieve all records where age at death is 18 years 
or younger. As there are no date restrictions, we do not require a date range as part of 
the statement. A suitable Conditions statement would be: 
SELECT all  
FROM   edeaths 
WHERE  DeceasedAge <=18 

The Export and Conditions tabs are: 
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Scenario 3 
In order to send a copy of the change in the Marriage Act to all Marriage Celebrants, 
an export file containing mailing addresses is required. The report is only sent to 
Marriage Celebrants registered on 31 December in the given year. The export should 
produce a CSV file. 

Solution 

Since we are dealing with people, the Scheduled Export needs to be created in the 
Parties module. The data is generated annually, so the Annually export frequency 
should be used. The Day nnn and Month mmm of Each Year should be set to Day 1 
and Month January of Each Year. As the export is run early in the morning on 1 
January, it will include all records up to and including 31 December. As CSV 
(Comma Separated Values) output is required, the Filter should be set to CSV Format 
(iso-8899-1). 

The Conditions statement needs to find all Marriage Celebrants registered on 31 
December. We only need to find Parties records containing a Type of Marriage 
Celebrant. A suitable Conditions statement is: 
SELECT all 
FROM eparties 
WHERE true and 
( 
 not 
 ( 
  NamOrganisation contains 'Cancelled' 
 ) 
) 
and 
( 
 NamPartyType contains 'MarriageCelebrant' 
) 

The required Export and Conditions tabs are: 

 In this example the Conditions statement was copied from the Show Search 
dialog box. See Hint - Determining the TexQL Conditions statement (page 13) for 
more details. 
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Scenario 4 
From time to time the Cancer Council requests a data file containing a list of all 
deceased persons who died of cancer. 

Solution 

The data exports are not required on a regular basis, so the Adhoc export frequency 
should be used. As a schedule is not defined for Adhoc exports you will need to run 
an Unscheduled Export to produce the required data file. See Unscheduled Exports 
(page 27) for more details. 

The Conditions statement needs to retrieve all cancer related deaths. The Cause of 
Death field allows us to find the required Deaths records. A suitable Conditions 
statement would be: 
SELECT all  
FROM   edeaths 
WHERE ImmediateCauseOfDeath CONTAINS 'Cancer' 

The required Export and Conditions tabs are: 
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Unscheduled Exports 
The Scheduled Exports facility allows you to have data exports occur at defined date 
intervals. It may also be useful to perform a data export immediately rather than at the 
scheduled time. In this case, we generate the export data by running the export 
manually. These manual runs are known as Unscheduled Exports. 

Another difference between an Unscheduled and Scheduled Export is that 
Unscheduled Exports use the current matching records as the data source, whereas a 
Scheduled Export uses the Conditions statement to retrieve the records to be exported. 
Unscheduled Exports ignore the Conditions statement. 
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Running Unscheduled Exports 
To run an Unscheduled Export: 

1. Search for or otherwise list a group of records. 
2. Select Tools>Exports in the Menu bar. 

-OR- 
Use the keyboard shortcut, ALT+T+X. 
The Exports dialog box displays: 

 
3. Select the export to run. 

4. Select Export  to export the current record or selected records 
-OR- 

Select Export All  to export all listed records. 
The export is run with a status dialog box displayed. When the export has 
finished, a completed dialog box displays: 

 

5. Select OK . 
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The results of the export are stored on the Vitalware server. To view the results it 
is necessary to look in the Exports module. See Viewing Export Results (page 
31) for more details. 
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Viewing Export Results 
Scheduled Exports are run automatically by Vitalware. For each export executed a 
record is created in the Exports module. The record includes: 

• Name of the Scheduled Export 
• Number of records exported 
• The module from which the records were exported 
• The filter used (if any) 
• The #STARTDATE# and #ENDDATE# values used 
• Any errors that occurred 
• The export data files 
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View Export Results 

1. Select Exports  from the Command Center. 
The Exports module displays in Search mode. 

2. Enter the name of the Export to view in Schedule: (Export Details).  

 If you're looking for a recently run export, you could run a search without 
entering search terms in Schedule: (Export Details) as exports are listed with 
most recent exports first. 

3. Select File>Search in the Menu bar 
-OR- 

Select Search  in the Toolbar 
-OR- 
Use the keyboard shortcut, CTRL+F. 
A list of matching exports displays: 

 
4. Select the export you want to view. 
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5. Select View>Details in the Menu bar 
-OR- 

Select View Details  in the Toolbar 
-OR- 
Use the keyboard shortcut, ALT+V+D. 
The details of the export displays: 

 
The export files generated in the export process are listed in the Export Files 
table. The files are stored on the Vitalware server. Any messages or errors are 
shown in the Filter Output box. 
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View Export Data 
1. Click the row in the Export Files table with the file to be viewed. 

2. Select Launch Viewer  next to the Export Files table. 
-OR- 
Select Exports>Launch in the Menu bar and select the file to be viewed from 
the sub-menu that displays. 

The application / viewer associated with the file extension is invoked to display the 
file. 

 

Save all Export Data files 

1. Select Save All  beside the Export Files table 
-OR- 
Select Exports>Save>All in the Menu bar. 
The Browse for Folder dialog box displays. 

2. Choose the directory into which all export files will be saved. 

3. Select OK . 
 

Save an Export Data file 
1. Select Exports>Save in the Menu bar 

-OR- 
Use the keyboard shortcut, ALT+X+S. 
The Save sub-menu lists all export data files. 

2. Select the file to save from the sub-menu. 
The Save As dialog box displays. 

3. Choose the location to save the export file. 

4. Select Save . 
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The Schedules and Exports Modules 
The Scheduled Exports facility uses two modules to store export details: 

• Schedules Module  
The Schedules module holds one record for each export defined in the Export 
Properties dialog box: 

 
The Scheduled Export settings on the Schedule, Fields, Conditions and Exports 
tabs are read-only as the values are maintained via the Export Properties dialog 
box; all other Tabs are editable. 
The Exports tab lists all data exports performed via this Schedules record. The 
list is sorted from most recent export to the oldest. Both Scheduled and 
Unscheduled Exports are shown: 
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• Exports Module  
The Exports module holds one record per export executed. An Exports record is 
linked to its associated Schedules record: 
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The Export Files table lists all files created when the export was run, along with 
their size. Any messages or errors generated display in the Filter Output box. 
Data values displaying on the Export tab are read-only; all other Tabs are 
editable. 
As with other Vitalware modules, the Schedules and Exports modules provide 
reporting, sorting, etc. 
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Creating Filters 
When defining a Scheduled Export in the Export Properties dialog box, it is possible 
to select a filter that transforms the standard XML export data format into another 
format suitable for delivery (e.g. CSV). If a filter is not specified, the export files 
contain Vitalware XML formatted data (as used by the Vitalware reporting facility). 
As final delivery formats may vary widely, System Administrators may need to create 
localized filters. In this section we look at how to add a filter into the Scheduled 
Exports facility. 

 

Where are filters stored? 
Filters, which are programs or scripts, reside under the etc/exports or 
local/etc/exports directory on the Vitalware server.  

They may be module specific or may be applicable to all modules. Module specific 
filters are stored under a sub-directory named after the module to which they apply. 
For example, Parties module specific filters would be located under 
etc/exports/eparties or local/etc/exports/eparties.  

 When adding your own filters to the Vitalware server, they should be placed 
under local/etc/exports as etc/exports is reserved for use by Vitalware 
upgrades. 

The name of the file containing the program or script is the label displayed in the 
Filters drop list when specifying a new Scheduled Export. 
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How is a filter invoked? 
When an export is performed the initial data export is in Vitalware XML format. The 
data is placed in a temporary file on the Vitalware server and passed as an argument 
to the filter specified for the Scheduled Export. The filter receives only one argument, 
the name of the file containing the exported data. 

Several environment variables are set and available to the filter when it executes: 

EXPORTTITLE The title given to the Scheduled Export when it 
was created. 

EXPORTIRN The IRN (Internal Record Number) of the 
Schedules record used to generate the exported 
data file. Using EXPORTIRN it is possible to 
retrieve details from the Schedules record. 

EXPORTTABLE The module from which the data was exported. 

EXPORTSTARTDAT
E 

The value of #STARTDATE# used by the export 
process. 

EXPORTENDDATE The value of #ENDDATE# used by the export 
process. 

EXPORTRECORDCO
UNT 

The number of records exported. 

 
 

Filter Output and Errors 
If the filter is unable to process the exported data, any error messages should be 
written to STDERR and the export terminated with a non-zero exit status. This notifies 
Vitalware that the filter did not complete successfully and an export failure is 
recorded. Any text written to STDERR is displayed in the Filter Output box for an 
Exports record in the Exports module. 

Once the filter has processed the export data it should print out to STDOUT a list of all 
the files generated. These files are moved under the logs/exports directory on the 
Vitalware server. The file names are displayed in the Export Files table in the Exports 
record created. If the filter completed successfully, it should return a zero exit status. 
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Filtering Data 
The filter may manipulate the export data in any way required. It may email the data 
(via sendmail), print it (via lpr or lp) or even send it to remote machines (via rsh or 
ssh). A copy of the data exported should always be attached to the Export record so it 
can be reviewed at a later date, if required. 
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An example filter 
In this example filter we convert the export data from XML to CSV (Comma 
Separated Values) and email the file(s) produced to a mail alias address 
(csvexport@client.org) on our local mail server. The mail server will then forward 
the email onto a host of recipients. 

We can use texxmlodbc to convert the export XML to CSV files. The filter is written 
using the perl scripting language as it provides a nice package for sending multi-part 
email messages. 

The filter is: 
#!/usr/bin/perl 
 
use strict; 
use warnings 'all'; 
use MIME::Lite; 
 
# 
#  First we convert the Vitalware XML to CSV and save 
#  the list of files generated. 
# 
if (! open(FILES, "texxmlodbc --output-encoding=iso-8859-1 '$ARGV[0]' 
|")) 
{ 
        print STDERR "Cannot execute texxmlodbc"; 
        exit(1); 
} 
my @files = <FILES>; 
close(FILES); 
 
# 
#  Build up the message to send. 
# 
my $body = <<END; 
The attached files were generated by the VW Scheduled Export 
facility. 
The details of the export are: 
 
Title: $ENV{EXPORTTITLE} 
Module: $ENV{EXPORTTABLE} 
Start Date: $ENV{EXPORTSTARTDATE} 
End Date: $ENV{EXPORTENDDATE} 
END 
 
# 
#  Create an email message to csvexport@client.org 
# 
my $msg = MIME::Lite->new( 
        To      => 'csvexport@client.org', 
        Subject => 'VW Scheduled Export CSV Files', 
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        Type    => 'multipart/mixed' 
        ); 
 
# 
#  Add the email text first. 
# 
$msg->attach( 
        Type    => 'TEXT', 
        Data    => $body 
        ); 
 
# 
#  Add each file. 
# 
foreach my $file (@files) 
{ 
        # 
        #  Figure out the file mime type and attach it 
        # 
        chomp($file); 
        my $type = ($file =~ /\.ini$/i) ? 'TEXT' : 'text/csv'; 
        $msg->attach( 
                Type            => $type, 
                Path            => $file, 
                Disposition     => 'attachment' 
                ); 
} 
 
# 
#  Send the email. 
# 
if (! $msg->send()) 
{ 
        print STDERR 'Cannot send email to csvexport@client.org'; 
        exit(1); 
} 
print STDERR 'Email sent to csvexport@client.org successfully'; 
 
# 
#  Output the file list for the export record. 
# 
print join("\n", @files); 
exit(0); 

Notice how the filter outputs the names of the CSV files at the end so they can be 
attached to the Export record created. Once attached these files may be reviewed at 
any time. 
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Cron setup 
In order for Scheduled Exports to be produced the vwexport command must be run, 
typically early each morning. The server based cron facility provides this ability. The 
following crontab entry needs to be installed to ensure the correct functioning of the 
Scheduled Export facility: 
0 1 * * * ~vw/bin/vwrun vwexport 2>&1 | ~vw/bin/vwrun vwlogger -t "KE 
Vitalware Scheduled Exports Report" exports 

where ~vw is replaced with the full path to where Vitalware is installed on the server 
machine.  

The time at which the command is run (1:00 am in the example above) should be 
adjusted to fit in with any Vitalware maintenance scheduled. 
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Using vwexport 
The vwexport command is the program used to execute Scheduled Exports. It 
interacts with the Schedules and Exports modules to ensure that data exports occur 
when scheduled. The program may be used in four different ways: 

1. Run all Scheduled Exports 
Usage: vwexport 
Any Scheduled Exports required to be run will be executed. The current date is 
used to determine what exports are required. This form of the command is used 
by cron on a daily basis to ensure all Scheduled Exports for the given day are 
performed. 

2. Run an Unscheduled Export 
Usage: vwexport -f filename -g recordcount -i irn 
The filename argument is the path to a file containing the export data in 
Vitalware XML format. A suitable file can be generated using the Vitalware 
reporting facility and selecting a Report Type of Export XML Document. The 
recordcount is the number of records in the XML file and irn is the IRN of 
the Schedules record to execute. An Unscheduled Export run within Vitalware 
uses this form of vwexport. 

3. Run Scheduled Exports for a specific date 
Usage: vwexport -R date [-i irn] 
The date argument indicates the date to use to determine what Scheduled 
Exports need to be run. The date format expected is yyyy/mm/dd. An optional 
IRN of a Schedules record may be supplied to force a particular Scheduled 
Export to execute using the supplied date. This form of vwexport is useful for re-
running Scheduled Exports for a given date, generally because of problems with 
the nightly automatic run. It can also be used for internal testing of vwexport. 

4. Run a specific Scheduled Export 
Usage: vwexport -i irn [-s startdate -e enddate] 
The irn argument is the IRN of a Schedules record to be executed. Optional 
startdate and enddate values (in yyyy/mm/dd format) may be used to 
override the computed #STARTDATE# and #ENDDATE# values respectively. This 
form of vwexport is very useful for testing filters as it allows a specific schedule 
to be run without waiting for the Scheduled Export date to arrive. 

In all usages of vwexport the appropriate Exports record is created for each export 
executed. 
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